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PREFACE 

The initial programming, up to version 1.01, was done by Tom 

Andersen, Oslo. The final programming (version 2.01) has been done by 

Helge Nesteby (DigitalConsult, Oslo). Parts of the program are copyrighted 

by THINK Technologies, Inc. Macintosh is a trademark licensed to Apple 

Computers Inc., Image Writer and LaserWriter are trademarks of Apple 

Computers Inc., SuperPaint is the trademark of Silicon Beach Software 

Inc ., MacDraw is the trademark of Claris, and Microsoft Excel is a 

trademark of Microsoft Inc. Development of this program has partly been 

financed by the HELP-program (Institute of Marine Research, Bergen). 

p 
::· 

Figure 1. A herring otolith with daily increment, magnification 100 x. 
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INTRODUCTION 

There is an increasing interest in reading the daily increments in 

otoliths of marine fish larvae and juveniles, for ageing and estimation of 

daily growth rate (Anon. 1989). As part of a tool to read the daily incre

ments. the software programme OTO (Andersen and Moksness 1988) was 

developed in 1988 for the Apple Macintosh computers. The basic 

functions in the OTO program are similar to the programme developed 

earlier for MS-DOS computers at Southwest Fisheries Center, La Jolla. 

USA. The OTO programme can only be used to read manually the 

increments in otoliths by the use of an HEI Video digitizer and an Apple 

Macintosh computer, and to estimate the number of increments and the 

increment size in the otoliths from each individual fish. However, there 

are no features in the OTO-programme to calculate the average number of 

increments and the average increment size in the otoliths from more 

than one fish . To do such calculations. the data have to be transferred to 

spreadsheets like Microsoft Excel for processing. However, handling of 

data in such a way is time consuming. The programme OPS (Otolith 

population statistics) has been developed to reduce the handling time of 

the data to a minimum. The OPS programme has been developed to read 

the data files created by the programme OTO and process these files. The 

OPS programme can only be used on an Apple Macintosh computer with a 

mathematical coprosessor (Macintoch SE/30 or Macintoch 11-serie). 

Equipment needed 

The following software and hardware are necessary for running the 

programme: 

The OTO programme, version 1.06 or later 

Data files from the OTO programme. 

Th e OPS programme (address the 68881 coprosessor) , version 2 . 1 or 

late r , together with : 

Apple Macintosh SE/ 30 or Macintosh II 
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It is recommended to use System 6.05, Finder 6.1 and Imagewriter 
2. 7 or later versions of system files for the Apple Macintosh computers. 

Use of MultiFinder (System 6.05. Finder 6.1) will make the work easier . 

Also recommended are Imagewriter II and/ or LaserWriter 

What the OPS program does 

The OPS programme reads the OTO data files and calculate the average 

number of increments and increment size from selected OTO data files. 
The results can be produced as tables and charts, which can be saved as 

either Text- or PICT-files . 

1. STARTING THE PROGRAMME 

The logos of the programme OPS and the data-files created by this 

programme is shown in Fig. 2. The OPS programme is to be used on a 

Macintosh SE/30 or Macintosh II-serie. The OPS (version 2.1 or later) 

address the 68881 coprossor which increases the speed of the calculation 

in the programme. The programme is started either by double-clicking 

the programme logo or the data file logo. The logos of the OTO pro

gramme and the data files created by the OTO programme are shown in 

Fig. 3. 

)9 .,.• )9 

~ 
OPS 2 .1 

G7J 
~ 

OPS data-file [;Jj lfeightL;~ formula 
Length/radius formula 

Fig. 2. The logos of the programme OPS and the data-files created by this 
programme. Length/radius formula and weight/radius formula are data 
files created by OPS and contain the length to otolith relationship and 
weight to otolith relationship respectively . 

. .. .. 
((~ 

ll'Tll 

Oto 1 .06 Data file 

Fig. 3 . The logos of the programme OTO and the data files created by this 
programme. 

1.1 . Creating a new "OPS" data file 
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1.1 . Creating a new "OPS" data file 

For opening a new data file, choose New from the File menu (Fig. 4) . 

In the following window (Fig. 5) the user can either click on Open all and 

then click Done or Open for the selected OTO files that the user wants to 
have analyzed, and then click Done. While the programme processes the 

OTO data files, the computer leaves a window which indicates the pro

cessing of the OTO data files (Fig. 6). When all the OTO data files have 

been processed, the "Processed files" window automatically appears on 

the screen, showing all the OTO data files that have been processed. 

[ Ins<~ 
s <Ill(~ 
S<1L1<~ <l~ , ,, 

S<1t1e d~ h~ H t ,, , 
S<ll'H <•~ pic1 ' " 

t>rin t pic1 .. , 

Quit XQ 

Distribution Growth Settings 

Fig. 4 . Choosing New from the File menu. 
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S lijif Edit Population Distribution Growth Settings 

D Herring-301 
D Herring-302 
D Herring-303 
D Herring-304 
D Herring-305 
D Herring-306 
D Herring-307 
D Herring-308 

c:::> HO-SAG ITTR 

( [ j (~ ( t ) 

( CJriLI(~ ) 

( Open ) 
( Open all~) 

( Done ) 

Fig. 5. The user can either click on Open all and the Done or click Open 
for the selected OTO files that the user wants to have analyzed. and the 
Done. 

Edit Population Distribution Growth Settings 

Processed files 
Number Experiment Sample Date Species 

300 Skagerrak-8E St.4 15/3/88 Herring 

301 Skagerrak-SE St .4 15/3/88 Herring 

302 Skagerrak-8E St.4 15/3/88 Herring 

0 PROGRESS 

Processing file Herring-301 9 files 

Combining transects 1 89 .6 K 

Fig. 6 . The "Progress" Window which is shown while the OPS-programme 
processes the OTO-files. 



s File Edit Population Distribution Growth Settings 

Processed files 
Number I Experiment I Sample I Date I Species 

300 Skagerrak-8E St.4 15/3/88 Herring kJ. -
301 Skagerrak-8E St.4 15/3/88 Herring 

302 Skagerrak-8E St.4 15/3/88 Herring I 303 Skagerrak-8E St.4 15/3/88 Sild 

304 Skagerrak-8E St .4 15/3/88 Herring I 305 Skagerrak-8E St.5 15/3/88 Herring 

306 Skaaerrak-8E St.5 15/3/88 ~ Herrin a fO 

Fig. 7. When the processing of OTO files is finished. the new window is 
usually left as shown in this figure. 

1.2. Open an existing "OPS" data file 

9 

To open an existing data file. chose OPEN from the FILE menu (Fig. 8). 

and the desired data file is shown on the screen (Fig. 9). 

S<lll(~ 

S<we <J~,,, 

Sm1e <J~ h~~1t ,,, 

Smi(~ d~ pic1 '" 

Print pic1 '" 

Quit a€0 

Distribution Growth Settings 

Fig.8. Choosing Open to fetch existing data file. 
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I a OPS-Doto I 
CJ HO-SAG ITTA 

( [j<Ht ) 

( Dril•<~ J 

( Open ~ J 

( Cancel ) 

Fig. 9. The contents of a window after opening existing data file. 

1.3. Add OTO-files to an existing "OPS" data file 

If the user wants to add one or more OTO files to the one that is already 

processed by the OPS programme, he/ she can use Select population from 

the Population menu (Fig. 10). A new window will appear on the screen 

(Fig. 11) from which the user can select the OTO files he/she would like 

to add to the already processed OTO files. The proceeding windows are 

the same as in Fig. 6 and 7. 

S File Edit 

Show files 
Show estimates 
Show statistics 

Growth Settings 

Fig. 10. The Select population option in the Population menu when more 
OTO files are to be added to already processed OTO files . 



S File Distribution Growth Settings 

O Herring-301 
O Herring-302 
O Herring-303 
D Herring-304 
O Herring-305 
D Herring-306 
O Herring-307 
D Herring-308 

Fig. 11. Choosing the OTO-data.files. 

1.4. Saving data 

!1111! 

l!ilil 

CJ HD-SAGllTA 

( t: j (~ ( t ) 

( £1 rill c~ J 

( Open ) 
( Open all~) 

( Done ) 

1 1 

When you have processed OTO data files (data files created by the OTO 
programme), choose Save as from the File menu (Fig. 12) to save the 

processed OTO data files as a OPS data file. A window appears as shown 

in Fig. 13 with a default name given. In the example given in Fig. 13 the 

default name has been changed. 

After minor changes have been made to the data, choose Save from the 

File menu, since the file has already been established. If you leave the 

programme by Close or Quit (Fig. 14 and 15) and data are not saved, a 

window will appear (Fig. 16) asking if the changes made are to be saved. 

If you have made changes and want to save them, click Yes. 
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Edit Population Distribution Growth Settings 
N<~W 

D(H~n ,,, 

Close 

:•:N ocessed files 
:•:O imated parameters 

Summary statistics 
Min. Mean Max . 

30.0 36.2 41.0 

Saue as teHt. .. 21 .4 62.7 107 .0 

S<W(~ <I~ pic1 ... 3.9 13.4 23 .3 

9.3 10.4 11 .4 ....................................................... 
Print pic1 ... 100.9 174 .9 246 .7 

97.0 141.9 167.0 ....................................................... 

Quit XO 

Fig. 12. Choosing Save as for saving data the first time. 

I esi OPS-Data I 

St. dev. 

3.0 

27.0 

5.9 

0.7 

43.4 

21.3 

,., 
L.: H (~I Tlrl~J"··Sk <I 9 (~ rr<ik , .. Q e::> HD-SRGllTR 

[ [ j (H t ) 

( Uriti(~ ) 

ro 
Saue document as ... ( Saue ~ I Herring-Buchan-9-8~ I ( Cancel ) 

!ill!! 

Q] 

Fig. 13. Window after choosing Save as . The user can choose any name for 
the data file he/ she wishes. 



Population Distribution Growth Settings 

:•:N ocessed files 

imated parameters 

Summary statistics 
Min . Mean Max. 

30.0 36 .2 41.0 
. .. . .. . ..... . .. .... u ..... . . u ..... . . . ...... . . . ........ 

Saue as teHt ... 21.4 62 .7 107.0 

S<1l•(~ (I~ l)iC1 3 .9 13.4 23 .3 
" ' 

9 .3 10.4 1 1 .4 
..... .... . ..... ... . . .. . . . . . ........ . . . . . .. . u ....... . .. 

Print l)iC1 100.9 174 .9 246.7 
' " 97 .0 141 .8 167.0 

••• •• ••••• • •• • ••• •• o .. .- o .. o ooooo o oo o o o uno o o o o oooo o• 

Quit a€Q 

Fig. 14. Choosing Close from the File menu. 

St . dev. 

3.0 

27 .0 

5.9 

illiii 
0 .7 

43.4 

21 .3 

121 

Edit Population Distribution Growth Settings 
N<~W :o:N 
DfH~fL ,, :o:o 
Close 
Sm•e 
Saue as .. . 

Saue as teHt ... 
S<1l•e <1~ pic1 , .. 

f>rin t pic1 , .. 

Fig. 15. Chosing Quit from the File menu . 

Saue changes to 

Herring - Buchan- 9- 88 

( YES 

( NO 

(Cancel] 

Fig. 16. Window after choosing Quit or Close. 

1 3 
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2. STATISTICS AND DISTRIBUTIONS 

The OPS programme will automatically show the OTO files that have 
been processed in the "Processed files" window. This window can also be 

called up by choosing "Show files" from the "Population" menu. In 

addition, the length, wet weight, dry weight, the measured distance from 

the centre of the otolith to the first increment observed (Focus). the 

measured distance from the nucleus to the margin of the otolith (Radius) 
and the number of increment estimated (# Inc). will all be shown in the 

"Estimated parameters" window. This window will appear after choosing 

"Show estimates" from the "Population" menu. A "Summary statistics" 
window gives you the basic statistics of length, wet weight, dry weight, 

Focus, Radius and # Inc and the window are choosen from the 

"Population" menu as "Show statistics". The three windows are shown in 

Fig. 1 7. All three windows can be saved as text files by choosing "Save as 
Text ... " from the File menu. None of the windows can be copyed to the 

scrapbook or to another programme. 

File Edit Population Distribution Growth Settings 

Processed files 
~umber I Experiment Sample I Date I Species 

300 Ska9errak-8E St.4 15/3/88 Herring 

301 Skagerrak-8E St.4 15/3/88 Herring 

302 Skaqerrak-8E St.4 15/3/88 Herrin<! 

303 Estimated parameters 
304 Number I Length I Wet wt. I Dry wt. I Focus I Radius I •Inc. 

305 300 41 .0 107.0 23.30 10.2 246 .7 167 

306 301 37.0 61.5 13.32 10.5 170.9 153 

302 36.5 77.6 16.39 11 .4 192.6 143 

303 D Summary statistics 
304 Par am . I Count I Min. I Mean I Max. I St . dev . 
305 Length 10 30 .0 36.2 41.0 3 .0 

306 Wet wt . 10 21 .4 62 .7 107 .0 27.0 

Dry wt . 10 3.9 13.4 23 .3 5 .9 

Focus 10 9.3 10.4 11 .4 0.7 

Radius 10 100.9 174.9 246 .7 43.4 

• Inc . 10 97.0 141 .8 167 .0 21 .3 

Fig. 17. The three windows shown by the Population menu. 



1 5 

All the parameters in the "Summary statistics" window can be 
produced as graphs. This is done by choosing either of them from the 

"Distribution" menu (Fig. 18 and 19). The scale of the x- and y-axis can be 

changed by double clicking on one of the two axis (Fig. 23). 

A special case is when creating a graph of the hatch distribution (Fig. 

20). If the date-format used is not equal to the default date-format in the 

OPS programme, a window will appear to get the user to define the used 

date-format (Fig. 21}. If, somehow, something is wrong, the programme 

will inform the user that the chart could not be made (Fig. 22) . 

. -··. ' . ' . , . 
Distribution s File Edit Population Growth Settings 

Process Length I 
E Estimate Wet weight I - Dry weight S1 Nur D Sum SI.__ Focus 

SI 
Par am . I Count I M Radius x. I St.dev . 

Len9th 10 Ii Increments ~ 1 .0 3.0 lQ s 
Wet wt . 10 Hatching date 07 ·

0 27.0 
s 

ii Dry wt . 10 -' · "' ...... . "'T ... 3 .3 5 .9 s 
Focus 10 9 .3 10.4 11 .4 0 .7 

Ll Radius 10 100.9 174.9 246 .7 43.4 ~ - •Inc. 10 97 .0 141 .8 167.0 21 .3 -- l2J 

Fig. 18. Choosing charts from the Distribution menu . 
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File Edit Population Distribution Growth Settings 

Length distribution 
I 

E Wet weight distribution I 
I 

E 5 -
Dry weight distribution 

4 -
5 ~ 

3 - Focal radius distribution 
4 

~ 5 
2 - 3 - MaHimum radius distribution 

c 1 - 2 - 4 -
5 I 

0 - 1 - 3 - 4 - Increment count distribu1 

.=D= Hatching date distribution 6 -
6 5 -

-- 4 - ~ 

5 - - ,__ 
3 - -4 -

,..... 2 - -3 - -
2 - 1 - n 
1 - 0 I I I I I I I II n 60 80 1 00 1 20 1 40 1 60 1 80 20 
0 I I 

mai jun 

Fig. 19. The seven charts created by the Distribution window. 

Population 

Process 

Estimate 

Sum 
Count M 

38 

3 

Distribution 
Length 
Wet weight 
Dry weight 
Focus 
Radius 

Growth 

St.< 

.0 

.0 

Fig. 20. Choosing Hatching date from the Distribution menu. 



Select a ualid date formot for the dote : 

dd/mm/yyyy 
ddmmyyyy 
ddmmyy 
yyyy/dd/mm 
yyyy-dd-mm 
yy-dd-mm 

Figure 21. Selecting date format. 

89/5/23 

c~ OK Il 
( Concel J 

No uolid do to for plotting! 

(( Concel ) 

Fig. 22. Appearing window if the hatching chart can not be made. 

1 7 
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Edit Population Distribution Growth Settings 

Length distribution 

a-.-------------------

6 Y-aHis scaling 

Minimum ~ 
4 Ma Hi mum 8 

Stepsize 2 

2 
H-aHis scaling 

Minimum 20 
0 

~ 35 20 25 30 40 Maximum 50 

Stepsize 5 

( OK ) ( Cancel ) 

Fig. 23. To change the scale of the figure, double-click on one of the axes 
and a new window will appear in which the user can change the axes. 

2.1 Saving and printing windows from Population and Distribution menu 

The windows created by the Population menu can all be saved as Text 
files by choosing "Save as text ... " from the file menu {Fig. 24). The OPS

programme will give the user a default name for the Text file, but this can 

be changed by the user {Fig. 25). 

The graphs produced by the Distribution menu can either be saved as 

Text-files {Fig. 26 and 27) or PICT files {Fig. 29) by choosing "Save as 
text ... " or "Save as pict ... " from the File-menu. In addition the graphs can 

be printed on paper by choosing the "Print pict ... " option in the File menu. 

The Text files can be opened by a spreadsheet as MS Excel. In addition 

the Text file can either be saved with a comma or a period . When using 

the US format configuration (selected from the Control Panel in the Apple 

menu) the Text file will be saved with a period and when using the 

Norwegian format configuration. the Text file is saved with a comma. 



Edit Population Distribution Growth Settings 
New :•:N ocessed files 

:•:O imated parameters 
0(H~n ,,, 
Close 
S<1t•c~ 

Soue as ... 

Summary statistics 
Min . Mean Max . St . dev . 

30 .0 36 .2 41.0 3 .0 

21.4 62.7 107.0 27.0 

Print pic1 .. , 

3 .9 13 .4 23 .3 S.9 

11!1!! 

9 .3 10.4 1 1 .4 0 .7 

100 .9 174.9 246.7 43 .4 

97 .0 141.8 167.0 21.3 

Ou it ~o Q:] 

Fig. 24. The "Save as text ... " option from the File menu. 

s lajif Edit Population Distribution Growth Settings 

I C5l Otoliths I 
0t OP'> 0.90 
D OPS-Data 
<Ii 01 o LOG 
DOTO-data 

Saue table os TEHT file: 

Proc:essed files teHt 

c:::J HD-SRG IITR 

[ [ j (~ ( t ) 

[ Oriti e ) 

( Saue ~ 

( Cancel ) 

Fig. 25 . The "Save as text .. . " window with a default data file name. 

1 9 
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Edit Population Distribution Growth Settings 
N<~W 

DpPn .,, 
Close 
S<we 
Saue as ... 

Print pict. .. 

Quit XO 

20 25 30 35 40 45 so 

Fig. 26. The "Save as text ... " option from the File menu. 

I a OPS-Doto I 
D He1·1·in9···Buct1<1n .. ·9 .. HH 
D H<~1·1·in9 .. ·Sk <}9<~1 ·1·<1k ,,, 
D Me <1 n r <1 di <I I i n < n~ m ,, . 

Soue plot data as TEHT file: 

I I 

c:::> HO-SAG llTA 

( E j<H t J 

( Britie J 

[ Soue ) 

[ Cancel ) 

Fig. 27 . The window to save a graph as Text file. with a default file name . 
This default file name can be changed. 



S File Edit Formula Formot Dato Options 

Al I x l 

D Length distribution teHt 
B I C I D I 

1 x 2. ~ .. 5 ............................. 1~~- ~- ~-~ ....................... : ............................... ..... l.. 
2 30.000000 32.7SOOOG 1: l 3 ·········3·2·.·7·5·a·6'a·a····· .. ·3·5·:'5'0'6'0'6'cr .......................... ...... i .. 1 .................................... ~ .. 
: ................. ~.-~·-:·l~--~--~--~--~ .... -........... lf .·'.··~--~--~--~--~--~-·.-.-......................... ·.·.·.·.-.-.-.-.-.·.·.·.-.·.-.·.-.7.T.-. ........................ ·.·.-.·.·.·.·.-.-. .. -... -.·.·.·.-.·.-.·.··+·· 

6 ·······-~r,.-: ·O"a'60"6'c ·· ·······43-_· 7·ifo '60"c ············ .. ···················i"r .. ·······························r 
1 ·· · ······43".·1 ·s·a ·6a·a· ······· ~fr;·:·s·a ·6a·O"cr ·· · ····· · ········· ·· ······ ····· "D"r · · ············· · ····· · ···· ·· ········ ~·· 
a ........ ~i'6·:·~rn ·6'a·6c··· .... ··49·_·z-s·a·6'ffc ......... ....................... 0T .................................. r 

~---1······· · · ··· ······ · · ···· ·· ····· ··-- · • · ··· ·· ··· ······ · ···· ··· ··········· · · ······ ···· · ·· ·· · · ·· ··········· · ·· · · ·· • ·· · ···· · ···· · · ········ ·· · ·· · ··········· 
9 49 .2SOOOQ 52 .00000G 0 l l 

1 o ........ si:·60.60'6c·········5·;;r7·5·a·6a·a··· ·····························ar········· .. ·······················r·· 
1 1 ····· ····5·4·.-;is·a·6a·a········5·:i:·s·a·6a·6a······ .. ················ ······· .. 6' r·· ··························· ······· i·· 
1 z ······ .. 5·7·:·s·a'6a·O"a·········6·a-.·2·s·a·6cfa········· ····················· .. a·r···································r ·· 

•• • • • •••••••••••••••••••••••••••• ••• O ••••• • •••••• •• • • ••••••••••••••• •• • •• ••·• • • ••• ••••••• • ·•• ••••••••• • • • •••• • O•••• ••••••• ••••••• ••• •••• •• •••••••• •• • • 

13 : : : : 
>---·••••••• • • •••••••• •••••••••••·•• •• •• • • • ••••• • •••••• • • ••• •• •• •• ••·••• ••••• O• •• • ••••• ••••• •• • ••• •••• • ••••• •o. ••••••••••••••••• •••••••••• • •••••••• ••• • 0 • • 
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Fig. 28. The result of "Save as Text ... " displayed as a MS Excel worksheet. 
If the user wants to change the period (.) to a comma (,). it is done by 
using the "Replace ... " function in the "Formula" menu in MS Excel. 

le OPS-Dato I 
D Be1·1 ·in9 ··· Buctl<1n ··· 9 ·· HH 

D Herrin~r·· Sli:: <19e1T<1k '" 
D ~Hdn r<1di<1I irH n~m ,,, 

Soue plot as PI CT file: 

Length distribution pic:t 

c:::i HO-SAG ITTA 

( l:je<t J 

( nritie J 

[ Soue J 

( Cancel J 

Fig. 29. The window to save a graph as PICT file. with a default file name. 
This default file name can be changed . 
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3 . SETIINGS 

3. 1. Age offset 

Firstly set the "Age offset". This means the number of days missing 

from the hatching till the first increments. For herring there has been 

observed in enclosure experiments that approximately 10 increments are 
missing compared to the actual age of the herring larvae. After choosing 
"Age offset ... " from the Settings menu (Fig. 30). the user changes the 
default 0 in the next window (Fig. 31) to a value like 10 as in Fig. 32. 

Population Distribution 

Processed files 

Estimated parameters 

Summary statistics 
Length to radius formula .. . 
Weight to radius formula .. . 

Count Min . Mean .................................................................................................. . 
~~~--'-~~~-'-~~---'-~----! 

38 4.0 6.7 Choosing period (days) ... 

Fig. 30. Choosing "Age offset ... " from the Settings menu 

Age at edge of Focus: ltml days 

~ ( OK ) ( Cancel ) 

Fig. 31. The default values in the "Age offset" window. 

Age at edge of Focus: ~ days 

( OK ) ( Cancel ) 

Fig. 32. Changing the default values in the "Age offset" window. 



The user is now ready to estimate the average increment size of the 

selected OTO files and does so by choosing Increment size (µm) at age 
from the Growth menu (Fig. 39). 

3.2. Fish size to otolith radius relationship 
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To go from increment size to daily growth rate in length or weight. the 

user needs to establish a relationship between the radius of the otolith 

and the length or the weight (wet or dry) of the fish species. This 

relationship can be entered by choosing "Length to radius formula ... " (Fig. 

33) or "Weight to radius formula ... " (Fig. 35) from the Settings menu. The 

formula (relationship) is entered in window for length (Fig. 34) or for 

weight (Fig. 36). The formulas (regressions) entered can only use the 

same mathematical expressions as used in MS Excel. The symbol =is not 

allowed. Each formula can be saved as a uniqe data file (see Fig. 2 and Figs. 

34 and 36). The graph showing the daily length increment and daily 

weight increment are choosen by selecting "Length increment (mm/ d) at 
age" and "Weight increment at age" respectively from the Growth menu . 

The graphs showing the length and weight at age, are made by selecting 
"Length (mm) at age" and 'Weight at age" from the Growth menu. 

Growth ~1 ~ Settings 
Age offset (days) ... 

Weight to radius formula ... 

Choosing period (doys) ... 

Fig. 33. Choosing "Length to radius formula ... " from the Settings menu to 
enter a new relationship between the length of the fish and the radius of 
their otolith. 
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s File Edit Population Distribution Growth lllf ilQtl 

Enter formula L = f(r) for conuersion from 
otolith radius (r) to specimen length (L). 

-18.6+ 10. 7 •'1n1.r:1 

Open formula... ) 

Saue formula... ) 

( OK ) 

( Cancel ) 

Fig. 34. Enter a new relationship between the length of the fish and the 
radius of their otolith. Open an exixting formula by choosing "Open 
formula" or save a new formula by choosing "Save formula". A formula is 
accepted by choosing "OK". 

Growth ~] ~ Settings 
Rge offset (days) ... 

Length to radius formula ... 
Weight to radius formula ... 

Choosing period (days) ... 

Fig. 35. Choosing 'Weight to radius formula ... " from the Settings menu to 
enter a new relationship between the length of the fish and the radius of 
their otolith. 



a File Edit Population Distribution Growth 11111.Ufl 

Enter formula W = f(r) for conuersion fro[ll 
otolith radius (r) to specimen length (W). ~ 

0.090116+0.0030975 • r+0.0009-1577 • r 2-0.00 
0008876•.- 3+0.000000027399•.- ... 

Open formula ... 

Saue formula ... 

[ OK 

Cancel 
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Fig. 36. Enter a new relationship between the weight (wet or dry) of the 
fish and the radius of their otolith. 

3 .3. Choosing period 

All the measurements in the otoliths are done on a daily basis . How

ever, there are situations where the user will want to compare growth 

between cohorts over a period of several days. This can be done in the 

programme by selecting the choosing period option in the Settings menu 

(Fig. 3 7). This gives the user the option to average increment size over 

whatever period of days he/she likes (Fig. 38). 

Growth ~1 ~ Settings 
Rge offset (days) ... 

Length to radius formula .. . 
Weight to radius formula .. . 

C:hoosing period I.days.I ... .. 

Fig. 3 7 . Selecting the choosing period option in the Settings menu. 
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Auerage euery liml days 

( OK J ( Cancel J 

Fig. 38. Giving the number of days to average increment size data over. 

The default number is 1. 

4. CALCUIATION FROM THE TIME OF HATCHING OF THE FISH 

4 .1. Calculation of increment size 

The calculation of average increment size (Increment size (µm) at 
age). daily length increments (Length increment (mm/d) at age) and daily 

weight increments (Weight increment at age: both wet and dry weight) 

are all processed from the Growth menu. However, when using this menu, 

the user should be aware that all calculations are done from day 0 or the 
first increment. The length (LI) and weight increments (WI) are done 

according to the formulae: 

LI= (L2 - L1)/(t2 - t1) and WI= (W2 - W1)/(t2 - t1): where L1. L2. W1. 

W2 are length and weight at day t1 and t2. 

The first to be done is to set the "Age offset". This means the number 

of days missing from the hatching till the first increments. This is done in 

the Settings menu. It is also recommended to set the length and weight 

to radius relationship. 

The user is now ready to estimate the average increment size of the 
selected OTO files and does so by choosing Increment size (µm) at age 
from the Growth menu (Fig. 39). While the OPS-programme processes 

the graph a "Progress" window (Fig. 40) will appear on the screen till all 

data from all the OTO files have been processed . The resulting graph 

containing average values (thick line) and standard deviation (two thin 
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lines) will be shown in a new window (Fig. 41). The axes of the graph can 

be altered by double clicking on one of the axes and a new window will 

appear as shown in Fig. 42. The scale can be changed by changing the axis 

values in the window. 

Growth Distribution Settings ~1 ~ 
~~~~~~~-=---~~ 

Radius (.um) at age 

Increment size · (Cal. from day of sample) 

Length (mm) at age 
Length increment (mm/d) ot age 

Weight ot age 
Weight increment at age 
SGR (%/d) 

Fig. 39. Choosing the Increment size (µm) at age from the Growth menu 
to estimate the average increment size with standard deviation. 

s File Edit Population 1§1.Jiijlf Settings 

D PROGRESS 

Processing growth history # 2 Age : 18 

Fig. 40. The window appearing on the screen while the OPS programme 
processes the data. 
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Mean radial inr. ements 

2.0 ........------------------~ 

1.5 

1 .0 

0.5 

0 .0 ------------------~ 

0 50 100 150 200 

Fig. 41. An example of a graph produced by the "Increment size (µm) at 
age" option. 

Population Distribution Growth Settings 

Mean radial increments 

Y-aHis scaling 

Minimum ~ 
MaHimum 2.0 

Stepsize 0.5 

H-aHis scaling 

Minimum 0 

MaHimum 200 
50 100 

Stepsize 50 

( OK ) ( Cancel ) 

Fig. 42. The scale of the axes can be altered by double clicking on one of 
the axes. 
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4.2. Calculation of daily growth rate in length and weight 

To go from increment size to daily growth rate in length or weight. the 
user needs to establish a relationship between the radius of the otolith 

and the length or the weight (wet or dry) of the fish species. This 

relationship can be entered by choosing "Length to radius formula" (Fig. 

33) or 'Weight to radius formula" (Fig. 35) in the Settings menu. 

The graph showing the daily length increment and daily weight 

increment is chosen by selecting "Length increment (mm/d) at age" and 

"Weight increment at age" respectively from the Growth menu. The 

graphs showing the length and weight at age, are made by selecting 

"Length (mm) at age" and 'Weight at age" from the Growth menu. 

Gromth Distribution Settings ~1 ~ 
Radius (µm) at age 
Increment size (µm) at age 
Increment size - (Est. from day of sample) 

Length (mm) at age 
Length inc:rement 1:mm/d:1 at age 

Weight at age 
Weight increment at age 
SGR (3/d) 

Fig. 43. Choosing "Length increment (mm/d) at age" from the Growth 
menu to have the average length increments of the sampled fish 
backcalculated. 

4.3. Calculation of specific growth rate (%/d) 

The backcalculation of specific growth rate (%/d) is based upon the 

relationship between the otolith radius and the weight of the fish being 

known. This relationship has to be entered by using the Settings menu 

(see eh. 3 .2). 
The specific growth rate. SGR, is calculated according to the formula 

(Houde and Schekter. 1981) : 

SGR = (exp((ln (Wt2) - ln (Wt1)) I (t2-t1ll -1) * 100: where Wt1 and Wt2 
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are wet weights of fishes at days t 1 and t2. 

Growth Distribution Settings ~1 ~ 
Radius (.um) at age 
Increment size (µm) at age 
Increment size - (Est. from day of sample) 

Length (mm) at age 
Length increment (mm/d) at age 

Weight at age 
Weight increment at age 

Fig. 44. Choosing "SGR (0/o/d)" from the Growth menu to have 
backcalculated the specific growth rate (%/d) of the sampled fish. 

5. CALCULATION FROM THE TIME OF CAPTURE OF THE FISH 

This option gives the user the possibility to calculate the average 

increment size from the moment of capture of the fish and back to the 

moment of hatching. The option is useful when the user wants to com

pare recent growth between cohorts. 

5.1. Calculation of increment size 

. The average increment size from the moment of capture of the fish 

and back to the moment of hatching is calculated by choosing the 

Increment size - (Cal. from day of sample) option in the growth menu. By 

selecting the Choosing period (days) option in the Settings menu , the 

user will get calculated values over periods of more than one day. 



Growth Distribution Settings ~1 ~ 
~~~~~~~-=----~~ 

Radius (µm) at age 
Increment size (µm) at age 
lnc:rement size - 1t:a1. from day of samp1e:1 

Length (mm) at age 
Length increment (mm/d) et age 

Weight at age 
Weight increment at oge 
SGR (3/d) 
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Fig. 45. Choosing "Increment size - (Cal. from day of sample)" from the 
Growth menu to have the specific growth rate (%/d) of the sampled fish 
backcalculated. The calculation is done from the moment of capture and 
back to the moment of hatching. 

Select o uolid date format for the date : 

dd/mm/yyyy 
ddmmyyyy 
ddmmyy 
yyyy/dd/mm 
yyyy-dd-mm 
yy-dd-mm 

Fig. 46. Selecting date forma t. 

89/5/23 

Ctt OK 3 
( Cancel J 
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No ualid dot a for plotting! 

K Cancel J 

Fig. 4 7 . Appearing window if the hatching chart can not be made. 

6 . SAVE TABLES AND CHARfS 

The graphs can either be saved as Text files or as PICT files . The "Save 

as text ... " (Fig. 48) option saves the mean, standard deviation, number of 

count at age (days) . sum and sums of squars. An example is shown in Fig. 

49, with a text file open from MS Excel. The comma (.) can be changed to 

a period (.) by using the command Replace in MS Excel. By choosing Save 
as pict ... the figure will be save as PICT-file. which can later be read by 

programmes such as MacDraw. 



N<~Hl 

D(H~n ,,, 

Close 
S<lP(~ 

Saue as ... 

Print pict ... 

Quit XO 

0 .0 -+------.-----------.-----1 
0 50 100 150 200 

Fig. 48. The "Save as text ... " option from the File menu. 
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Fig. 49. The result of "Save as Text ... " displayed as an MS Excel worksheet. 
If the user wants to change the comma (.) to period (.), this is done by 
using the "Replace ... " function in the "Format" menu in MS Excel. 
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Fig. 50. The result of "Save as Text ... " displayed as an MS Excel worksheet. 
If the user wants to change the comma (.) to a period (.). this is done by 
using the "Replace ... " function in "Format" menu in MS Excel. 

6 . 1. Using comma or period when saving Text files 

The user can choose between comma or period when exporting data as 
text-files. This is done by setting the Format configuration to US format 

when period is to be used and Norwegian format when a comma is to be 
used. If the user wants to change format when in the programme, the 

computer has to be rebooted to get the new format. 

7. PRINT TABLES AND CHARTS 

Only Graphs can be printed. This is done by choosing "Print pict ... " 
from the File menu. 

8. COPY AND PASTE TABLES AND CHARTS 

The tables produced by the OPS programme cannot be copied to the 
Scrapbook or to another programme. It is recommended to save the 
Tables as Text files by using the "Save as text ... " option in the File menu. 

The graphs can all be copied to the Scrapbook or to programmes like MS 
Word, MacDraw or SuperPaint. However , parts of the graphs can be lost 

when you use th e copy function. It is therefore recommended to save the 
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graphs as PICT files for use in programmes like SuperPaint and MacDraw. 

Edit Population Distribution Growth Settings 

N(~W :e(N ~~~~[;:G~~~~~~~~~~~ OfH~n .,, :as:o ~ 
Close 
S<1 lie 
Saue as ... 

Saue as teKt. .. 
Sau e as p ic t... r-·..-.~"" .... .,..,a 

Quit XQ 

0 .0 -----.-----~-----.--------l 

0 50 100 150 200 

Fig. 51. The "Print pict ... " option from the File menu . 
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